Toyota C-HR Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone!
Have a 2018 XLE which I generally love. Yesterday I started the car and everything was just off - it felt slow, my settings where on the first page instead of where I always have them (on the mph/gas range page), the check engine light was taking a few extra seconds to turn off, I filled up the gas tank and instead of resetting to 259 like it ALWAYS does, it started at 250. Just weird. Did my drive to work, noticing the range wasn’t adjusting down like it normally would. Got to work, turned the car on and off and suddenly the range gave me 20 extra miles and the fuel gauge looked slightly higher. Okay really weird. Later in the day, the car would barely turn over to start, assumed all this was was the battery, it was the original/car has 70,000 miles on it, so got a replacement. The replacement battery fixed every issue but the gas. I filled it up again hoping it would go to the normal 259 but no, 246. Now driving around and the range is dropping fast but the needle isn’t moving. UGH. Is this an problem? A fluke? Will it fix itself? I don’t know. Anyone else having similar issues?
 

·
Registered
Joined
·
2 Posts
Hi everyone!
Have a 2018 XLE which I generally love. Yesterday I started the car and everything was just off - it felt slow, my settings where on the first page instead of where I always have them (on the mph/gas range page), the check engine light was taking a few extra seconds to turn off, I filled up the gas tank and instead of resetting to 259 like it ALWAYS does, it started at 250. Just weird. Did my drive to work, noticing the range wasn’t adjusting down like it normally would. Got to work, turned the car on and off and suddenly the range gave me 20 extra miles and the fuel gauge looked slightly higher. Okay really weird. Later in the day, the car would barely turn over to start, assumed all this was was the battery, it was the original/car has 70,000 miles on it, so got a replacement. The replacement battery fixed every issue but the gas. I filled it up again hoping it would go to the normal 259 but no, 246. Now driving around and the range is dropping fast but the needle isn’t moving. UGH. Is this an problem? A fluke? Will it fix itself? I don’t know. Anyone else having similar issues?
 

·
Registered
Joined
·
2 Posts
I am recently
Experiencing the same problem I just change my battery and then my gas tank was about 100 miles less with the rain should’ve been after filling up now my gas meter has not moved even though I’ve been driving for over two hours
 

·
Registered
Joined
·
10 Posts
Hello,

Yes, same problem. I recently changed my battery after 2 years on my 2019 as it was on it's way out. I noticed this because my display settings were not working properly. New Battery fixed that issue but also have noticed my "RANGE" is much less than it was before my battery replacement.

I think when the battery is disconnected, you might lose your data and it starts over the recalculation of the Miles Range. It may take a few months to recalibrate itself since this "Range" I think is an average over time and needs many tanks of gas to get an accurate reading. I will be monitoring the "Range" to see if goes back up over time in the next few months.

Stay Tuned???
 
1 - 4 of 4 Posts
Top