Toyota C-HR Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I’m getting an error message saying “Abnormal voltage power steering low”. I have an appointment to see dealer soon but wondering if anyone else has experienced this message? Any thoughts or advice?
 

·
Premium Member
Joined
·
466 Posts
I got that message before. Was pretty weird. Happened just after trying to turn my steering wheel in a parking lot, encountering no power assist, and then the warning message.

I've had other weird electronics issues over the past couple of months. Over the past weekend, I was performing a battery/electrical system test with my scan tool. I discovered the negative battery terminal loose. I had the car in for body work in November/December and know the body shop had disconnected the negative battery cable. I've tightened down the cable and so far no issues.

So I would check that or any engine grounds to see if they're loose or have rust/corrosion on them.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
I got that message before. Was pretty weird. Happened just after trying to turn my steering wheel in a parking lot, encountering no power assist, and then the warning message.

I've had other weird electronics issues over the past couple of months. Over the past weekend, I was performing a battery/electrical system test with my scan tool. I discovered the negative battery terminal loose. I had the car in for body work in November/December and know the body shop had disconnected the negative battery cable. I've tightened down the cable and so far no issues.

So I would check that or any engine grounds to see if they're loose or have rust/corrosion on them.
Thank you for the info! Guess I’ll see what the service department says and take it from there.
I‘m just hoping it’s not some precursor to a bad electrical problem.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top